]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Add the icon.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 75bdc675ddc57e730b703bbd641269b068d30e3a..077ff051da2a63c212052ae9c89fd16362bf3fe4 100644 (file)
@@ -1,23 +1,41 @@
-add_executable(privacybrowserpc)
+# Copyright © 2022 Soren Stoutner <soren@stoutner.com>.
+#
+# This file is part of Privacy Browser PC <https://www.stoutner.com/privacy-browser-pc>.
+#
+# Privacy Browser PC is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# Privacy Browser PC is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Privacy Browser PC.  If not, see <http://www.gnu.org/licenses/>.
 
-target_sources(privacybrowserpc PRIVATE
+# Create the executable and add the resources.
+add_executable(privacybrowser resources.qrc)
+
+target_sources(privacybrowser PRIVATE
     main.cpp
-    privacybrowserpcwindow.cpp
+    mainwindow.cpp
     privacybrowserpcview.cpp
 )
 
-ecm_qt_declare_logging_category(privacybrowserpc
+ecm_qt_declare_logging_category(privacybrowser
     HEADER privacybrowserpcdebug.h
-    IDENTIFIER PRIVACYBROWSERPC
-    CATEGORY_NAME "privacybrowserpc"
+    IDENTIFIER PRIVACYBROWSER
+    CATEGORY_NAME "privacybrowser"
 )
-kconfig_add_kcfg_files(privacybrowserpc PrivacyBrowserPCSettings.kcfgc)
-ki18n_wrap_ui(privacybrowserpc
+kconfig_add_kcfg_files(privacybrowser PrivacyBrowserPCSettings.kcfgc)
+ki18n_wrap_ui(privacybrowser
     privacybrowserpcview.ui
     settings.ui
 )
 
-target_link_libraries(privacybrowserpc
+target_link_libraries(privacybrowser
     KF5::CoreAddons
     KF5::I18n
     KF5::XmlGui
@@ -27,7 +45,7 @@ target_link_libraries(privacybrowserpc
     Qt5::Widgets
 )
 
-install(TARGETS privacybrowserpc ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
-install(PROGRAMS org.example.privacybrowserpc.desktop  DESTINATION ${KDE_INSTALL_APPDIR})
-install(FILES org.example.privacybrowserpc.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
-install(FILES privacybrowserpcui.rc DESTINATION ${KDE_INSTALL_KXMLGUI5DIR}/privacybrowserpc)
+install(TARGETS privacybrowser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
+install(PROGRAMS com.stoutner.privacybrowser  DESTINATION ${KDE_INSTALL_APPDIR})
+install(FILES com.stounter.privacybrowser.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
+install(FILES privacybrowserpcui.rc DESTINATION ${KDE_INSTALL_KXMLGUI5DIR}/privacybrowser)  # TODO