]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Enable setting as the default browser.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 2b5beb12619e52cb0ea1ea4a435e451ec7d96c5f..425f0e71e5c22634247e8eeaf5a4468207fdc6da 100644 (file)
@@ -21,9 +21,10 @@ add_executable(privacy-browser resources.qrc)
 
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
+    browserwindow.cpp
     main.cpp
-    mainwindow.cpp
     mainview.cpp
+    mouseeventfilter.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -39,20 +40,24 @@ kconfig_add_kcfg_files(privacy-browser settings.kcfgc)
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
     mainview.ui
-    settings.ui
+    settingsprivacy.ui
+    settingsgeneral.ui
 )
 
 # Link the following libraries.
 target_link_libraries(privacy-browser
-    KF5::ConfigWidgets
+    Qt5::Core
+    Qt5::Gui
+    Qt5::Widgets
+    Qt5::WebEngineWidgets
     KF5::Completion
+    KF5::ConfigWidgets
     KF5::CoreAddons
     KF5::Crash
     KF5::DBusAddons
+    KF5::DocTools
     KF5::I18n
     KF5::XmlGui
-    Qt5::Widgets
-    Qt5::WebEngineWidgets
 )
 
 # Install Privacy Browser using the default KDE arguments.