]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Clear the URL line edit when navigating history. https://redmine.stoutner.com/issues/841
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index d63efaf63864901b9ed8f927679120febd4724c0..4d33710bb035c2c688fd4caef84aa632a7d67d23 100644 (file)
 # You should have received a copy of the GNU General Public License
 # along with Privacy Browser PC.  If not, see <http://www.gnu.org/licenses/>.
 
-
 # Create the executable and add the resources.
 add_executable(privacy-browser resources.qrc)
 
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
-    BrowserWindow.cpp
     main.cpp
-    MainView.cpp
-    MouseEventFilter.cpp
-    UrlRequestInterceptor.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -36,19 +31,21 @@ ecm_qt_declare_logging_category(privacy-browser
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser Settings.kcfgc)
+kconfig_add_kcfg_files(privacy-browser settings/Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    MainView.ui
-    SettingsPrivacy.ui
-    SettingsGeneral.ui
+    ui/BrowserView.ui
+    ui/DomainSettingsDialog.ui
+    ui/SettingsGeneral.ui
+    ui/SettingsPrivacy.ui
 )
 
 # Link the following libraries.
 target_link_libraries(privacy-browser
     Qt5::Core
     Qt5::Gui
+    Qt5::Sql
     Qt5::Widgets
     Qt5::WebEngineCore
     Qt5::WebEngineWidgets
@@ -63,7 +60,13 @@ target_link_libraries(privacy-browser
 )
 
 # Add the subdirectories.
+add_subdirectory(dialogs)
+add_subdirectory(filters)
 add_subdirectory(helpers)
+add_subdirectory(interceptors)
+add_subdirectory(ui.rc)
+add_subdirectory(views)
+add_subdirectory(windows)
 
 # Install Privacy Browser using the default KDE arguments.
 install(TARGETS privacy-browser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
@@ -74,8 +77,5 @@ install(PROGRAMS com.stoutner.privacybrowser.desktop DESTINATION ${KDE_INSTALL_A
 # Install Privacy Browser's metadata file.
 install(FILES com.stoutner.privacybrowser.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
 
-# Install Privacy Browser's RC (Runtime Configuration) file.
-install(FILES privacybrowserui.rc DESTINATION ${KDE_INSTALL_KXMLGUI5DIR}/privacybrowser)
-
 # Install Privacy Browser's icon.
 ecm_install_icons(ICONS icons/sc-apps-privacy-browser.svg DESTINATION ${KDE_INSTALL_ICONDIR})