]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Clear the URL line edit when navigating history. https://redmine.stoutner.com/issues/841
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index d9f46da7d48fa1a142852007f3a83cdaf9741423..4d33710bb035c2c688fd4caef84aa632a7d67d23 100644 (file)
@@ -21,8 +21,6 @@ add_executable(privacy-browser resources.qrc)
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
     main.cpp
-    MouseEventFilter.cpp
-    UrlRequestInterceptor.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -33,14 +31,14 @@ ecm_qt_declare_logging_category(privacy-browser
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser Settings.kcfgc)
+kconfig_add_kcfg_files(privacy-browser settings/Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    BrowserView.ui
-    DomainSettingsView.ui
-    SettingsPrivacy.ui
-    SettingsGeneral.ui
+    ui/BrowserView.ui
+    ui/DomainSettingsDialog.ui
+    ui/SettingsGeneral.ui
+    ui/SettingsPrivacy.ui
 )
 
 # Link the following libraries.
@@ -62,10 +60,13 @@ target_link_libraries(privacy-browser
 )
 
 # Add the subdirectories.
+add_subdirectory(dialogs)
+add_subdirectory(filters)
 add_subdirectory(helpers)
+add_subdirectory(interceptors)
+add_subdirectory(ui.rc)
 add_subdirectory(views)
 add_subdirectory(windows)
-add_subdirectory(ui.rc)
 
 # Install Privacy Browser using the default KDE arguments.
 install(TARGETS privacy-browser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})