]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Fix the application of Domain Settings when navigating history. https://redmine.stout...
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 79526bf4ea6b772d6dbbc287075b3472458baf3d..709b74ca16e6f9d88746142cce3062097e4bde32 100644 (file)
 # You should have received a copy of the GNU General Public License
 # along with Privacy Browser PC.  If not, see <http://www.gnu.org/licenses/>.
 
-
 # Create the executable and add the resources.
 add_executable(privacy-browser resources.qrc)
 
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
-    BrowserWindow.cpp
     main.cpp
-    MainView.cpp
     MouseEventFilter.cpp
 )
 
@@ -39,16 +36,19 @@ kconfig_add_kcfg_files(privacy-browser Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    MainView.ui
-    SettingsPrivacy.ui
+    BrowserView.ui
+    DomainSettingsDialog.ui
     SettingsGeneral.ui
+    SettingsPrivacy.ui
 )
 
 # Link the following libraries.
 target_link_libraries(privacy-browser
     Qt5::Core
     Qt5::Gui
+    Qt5::Sql
     Qt5::Widgets
+    Qt5::WebEngineCore
     Qt5::WebEngineWidgets
     KF5::Completion
     KF5::ConfigWidgets
@@ -61,7 +61,12 @@ target_link_libraries(privacy-browser
 )
 
 # Add the subdirectories.
+add_subdirectory(dialogs)
 add_subdirectory(helpers)
+add_subdirectory(interceptors)
+add_subdirectory(ui.rc)
+add_subdirectory(views)
+add_subdirectory(windows)
 
 # Install Privacy Browser using the default KDE arguments.
 install(TARGETS privacy-browser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
@@ -72,8 +77,5 @@ install(PROGRAMS com.stoutner.privacybrowser.desktop DESTINATION ${KDE_INSTALL_A
 # Install Privacy Browser's metadata file.
 install(FILES com.stoutner.privacybrowser.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
 
-# Install Privacy Browser's RC (Runtime Configuration) file.
-install(FILES privacybrowserui.rc DESTINATION ${KDE_INSTALL_KXMLGUI5DIR}/privacybrowser)
-
 # Install Privacy Browser's icon.
 ecm_install_icons(ICONS icons/sc-apps-privacy-browser.svg DESTINATION ${KDE_INSTALL_ICONDIR})