]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Enable downloading of files that require login cookies. https://redmine.stoutner...
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index d80c89d7ca56e3fde102f18fe7c8ab14a0ff5d9a..8278a21d38fb71d90ca7699b197eaf1c07a8b32a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright © 2022 Soren Stoutner <soren@stoutner.com>.
+# Copyright 2022 Soren Stoutner <soren@stoutner.com>.
 #
 # This file is part of Privacy Browser PC <https://www.stoutner.com/privacy-browser-pc>.
 #
@@ -61,6 +61,7 @@ target_link_libraries(privacy-browser
     KF5::DBusAddons
     KF5::DocTools
     KF5::I18n
+    KF5::Notifications
     KF5::KIOCore
     KF5::KIOWidgets
     KF5::XmlGui
@@ -86,5 +87,8 @@ install(PROGRAMS com.stoutner.privacybrowser.desktop DESTINATION ${KDE_INSTALL_A
 # Install Privacy Browser's metadata file.
 install(FILES com.stoutner.privacybrowser.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
 
+# Install Privacy Browser's notifyrc file.
+install(FILES privacybrowser.notifyrc DESTINATION ${KDE_INSTALL_KNOTIFYRCDIR})
+
 # Install Privacy Browser's icon.
 ecm_install_icons(ICONS icons/sc-apps-privacy-browser.svg DESTINATION ${KDE_INSTALL_ICONDIR})