]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Add user agent controls.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 1043918135943e9c0b8c46e380b186fed6d08767..8f184ad26ee8ff6a3f9ade1726e2e36390774ec3 100644 (file)
@@ -21,10 +21,11 @@ add_executable(privacy-browser resources.qrc)
 
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
-    browserwindow.cpp
+    BrowserWindow.cpp
     main.cpp
-    mainview.cpp
-    mouseeventfilter.cpp
+    MainView.cpp
+    MouseEventFilter.cpp
+    UserAgentHelper.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -35,25 +36,29 @@ ecm_qt_declare_logging_category(privacy-browser
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser settings.kcfgc)
+kconfig_add_kcfg_files(privacy-browser Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    mainview.ui
-    settings.ui
+    MainView.ui
+    SettingsPrivacy.ui
+    SettingsGeneral.ui
 )
 
 # Link the following libraries.
 target_link_libraries(privacy-browser
-    KF5::ConfigWidgets
+    Qt5::Core
+    Qt5::Gui
+    Qt5::Widgets
+    Qt5::WebEngineWidgets
     KF5::Completion
+    KF5::ConfigWidgets
     KF5::CoreAddons
     KF5::Crash
     KF5::DBusAddons
+    KF5::DocTools
     KF5::I18n
     KF5::XmlGui
-    Qt5::Widgets
-    Qt5::WebEngineWidgets
 )
 
 # Install Privacy Browser using the default KDE arguments.