]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Add user agent controls.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 513e8e6222eaab9b6491411bc0ddf437ce0d9802..8f184ad26ee8ff6a3f9ade1726e2e36390774ec3 100644 (file)
@@ -21,36 +21,44 @@ add_executable(privacy-browser resources.qrc)
 
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
+    BrowserWindow.cpp
     main.cpp
-    mainwindow.cpp
-    mainview.cpp
+    MainView.cpp
+    MouseEventFilter.cpp
+    UserAgentHelper.cpp
 )
 
-# Add the Qt logging category.  This will create the `privacybrowserdebug.h` header file.
+# Add the Qt logging category.  This will create the `debug.h` header file.
 ecm_qt_declare_logging_category(privacy-browser
-    HEADER privacybrowserdebug.h
+    HEADER debug.h
     IDENTIFIER PRIVACYBROWSER
     CATEGORY_NAME "privacybrowser"
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser settings.kcfgc)
+kconfig_add_kcfg_files(privacy-browser Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    mainview.ui
-    settings.ui
+    MainView.ui
+    SettingsPrivacy.ui
+    SettingsGeneral.ui
 )
 
 # Link the following libraries.
 target_link_libraries(privacy-browser
+    Qt5::Core
+    Qt5::Gui
+    Qt5::Widgets
+    Qt5::WebEngineWidgets
+    KF5::Completion
     KF5::ConfigWidgets
     KF5::CoreAddons
     KF5::Crash
     KF5::DBusAddons
+    KF5::DocTools
     KF5::I18n
     KF5::XmlGui
-    Qt5::Widgets
 )
 
 # Install Privacy Browser using the default KDE arguments.
@@ -66,4 +74,4 @@ install(FILES com.stoutner.privacybrowser.appdata.xml DESTINATION ${KDE_INSTALL_
 install(FILES privacybrowserui.rc DESTINATION ${KDE_INSTALL_KXMLGUI5DIR}/privacybrowser)
 
 # Install Privacy Browser's icon.
-ecm_install_icons(ICONS icons/sc-apps-privacy_browser.svg DESTINATION ${KDE_INSTALL_ICONDIR})
+ecm_install_icons(ICONS icons/sc-apps-privacy-browser.svg DESTINATION ${KDE_INSTALL_ICONDIR})