]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Reapply domain settings when the host changes.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 320ae9dd5fb569090398d14f287dfaeb837ac2c0..d63efaf63864901b9ed8f927679120febd4724c0 100644 (file)
@@ -21,9 +21,11 @@ add_executable(privacy-browser resources.qrc)
 
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
-    browserwindow.cpp
+    BrowserWindow.cpp
     main.cpp
-    mainview.cpp
+    MainView.cpp
+    MouseEventFilter.cpp
+    UrlRequestInterceptor.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -34,27 +36,35 @@ ecm_qt_declare_logging_category(privacy-browser
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser settings.kcfgc)
+kconfig_add_kcfg_files(privacy-browser Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    mainview.ui
-    settings.ui
+    MainView.ui
+    SettingsPrivacy.ui
+    SettingsGeneral.ui
 )
 
 # Link the following libraries.
 target_link_libraries(privacy-browser
-    KF5::ConfigWidgets
+    Qt5::Core
+    Qt5::Gui
+    Qt5::Widgets
+    Qt5::WebEngineCore
+    Qt5::WebEngineWidgets
     KF5::Completion
+    KF5::ConfigWidgets
     KF5::CoreAddons
     KF5::Crash
     KF5::DBusAddons
+    KF5::DocTools
     KF5::I18n
     KF5::XmlGui
-    Qt5::Widgets
-    Qt5::WebEngineWidgets
 )
 
+# Add the subdirectories.
+add_subdirectory(helpers)
+
 # Install Privacy Browser using the default KDE arguments.
 install(TARGETS privacy-browser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})