]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Reapply domain settings when the host changes.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 425f0e71e5c22634247e8eeaf5a4468207fdc6da..d63efaf63864901b9ed8f927679120febd4724c0 100644 (file)
@@ -21,10 +21,11 @@ add_executable(privacy-browser resources.qrc)
 
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
-    browserwindow.cpp
+    BrowserWindow.cpp
     main.cpp
-    mainview.cpp
-    mouseeventfilter.cpp
+    MainView.cpp
+    MouseEventFilter.cpp
+    UrlRequestInterceptor.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -35,13 +36,13 @@ ecm_qt_declare_logging_category(privacy-browser
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser settings.kcfgc)
+kconfig_add_kcfg_files(privacy-browser Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    mainview.ui
-    settingsprivacy.ui
-    settingsgeneral.ui
+    MainView.ui
+    SettingsPrivacy.ui
+    SettingsGeneral.ui
 )
 
 # Link the following libraries.
@@ -49,6 +50,7 @@ target_link_libraries(privacy-browser
     Qt5::Core
     Qt5::Gui
     Qt5::Widgets
+    Qt5::WebEngineCore
     Qt5::WebEngineWidgets
     KF5::Completion
     KF5::ConfigWidgets
@@ -60,6 +62,9 @@ target_link_libraries(privacy-browser
     KF5::XmlGui
 )
 
+# Add the subdirectories.
+add_subdirectory(helpers)
+
 # Install Privacy Browser using the default KDE arguments.
 install(TARGETS privacy-browser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})