]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Reapply domain settings when the host changes.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 79526bf4ea6b772d6dbbc287075b3472458baf3d..d63efaf63864901b9ed8f927679120febd4724c0 100644 (file)
@@ -25,6 +25,7 @@ target_sources(privacy-browser PRIVATE
     main.cpp
     MainView.cpp
     MouseEventFilter.cpp
     main.cpp
     MainView.cpp
     MouseEventFilter.cpp
+    UrlRequestInterceptor.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -49,6 +50,7 @@ target_link_libraries(privacy-browser
     Qt5::Core
     Qt5::Gui
     Qt5::Widgets
     Qt5::Core
     Qt5::Gui
     Qt5::Widgets
+    Qt5::WebEngineCore
     Qt5::WebEngineWidgets
     KF5::Completion
     KF5::ConfigWidgets
     Qt5::WebEngineWidgets
     KF5::Completion
     KF5::ConfigWidgets