]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Reapply domain settings when the host changes.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 8f184ad26ee8ff6a3f9ade1726e2e36390774ec3..d63efaf63864901b9ed8f927679120febd4724c0 100644 (file)
@@ -25,7 +25,7 @@ target_sources(privacy-browser PRIVATE
     main.cpp
     MainView.cpp
     MouseEventFilter.cpp
-    UserAgentHelper.cpp
+    UrlRequestInterceptor.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -50,6 +50,7 @@ target_link_libraries(privacy-browser
     Qt5::Core
     Qt5::Gui
     Qt5::Widgets
+    Qt5::WebEngineCore
     Qt5::WebEngineWidgets
     KF5::Completion
     KF5::ConfigWidgets
@@ -61,6 +62,9 @@ target_link_libraries(privacy-browser
     KF5::XmlGui
 )
 
+# Add the subdirectories.
+add_subdirectory(helpers)
+
 # Install Privacy Browser using the default KDE arguments.
 install(TARGETS privacy-browser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})