]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Initial Cookies implementation using a QVBoxLayout.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 55b3e3f75911dd82616e6361a452f080098d5ba0..ea4fecb7f4d06c0c4c9e9662061853898b913342 100644 (file)
@@ -21,8 +21,6 @@ add_executable(privacy-browser resources.qrc)
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
     main.cpp
-    MouseEventFilter.cpp
-    UrlRequestInterceptor.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -33,14 +31,16 @@ ecm_qt_declare_logging_category(privacy-browser
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser Settings.kcfgc)
+kconfig_add_kcfg_files(privacy-browser settings/Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    BrowserView.ui
-    DomainSettingsDialog.ui
-    SettingsGeneral.ui
-    SettingsPrivacy.ui
+    ui/BrowserView.ui
+    ui/CookiesDialog.ui
+    ui/CookieWidget.ui
+    ui/DomainSettingsDialog.ui
+    ui/SettingsGeneral.ui
+    ui/SettingsPrivacy.ui
 )
 
 # Link the following libraries.
@@ -63,7 +63,9 @@ target_link_libraries(privacy-browser
 
 # Add the subdirectories.
 add_subdirectory(dialogs)
+add_subdirectory(filters)
 add_subdirectory(helpers)
+add_subdirectory(interceptors)
 add_subdirectory(ui.rc)
 add_subdirectory(views)
 add_subdirectory(windows)