]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Rename Local Storage to DOM Storage. https://redmine.stoutner.com/issues/852
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 1043918135943e9c0b8c46e380b186fed6d08767..fb702314c31b9b49bd0efa8c8bb54197c18679d0 100644 (file)
 # You should have received a copy of the GNU General Public License
 # along with Privacy Browser PC.  If not, see <http://www.gnu.org/licenses/>.
 
-
 # Create the executable and add the resources.
 add_executable(privacy-browser resources.qrc)
 
 # List the sources to include in the executable.
 target_sources(privacy-browser PRIVATE
-    browserwindow.cpp
     main.cpp
-    mainview.cpp
-    mouseeventfilter.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
@@ -35,27 +31,46 @@ ecm_qt_declare_logging_category(privacy-browser
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser settings.kcfgc)
+kconfig_add_kcfg_files(privacy-browser settings/Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
 ki18n_wrap_ui(privacy-browser
-    mainview.ui
-    settings.ui
+    uis/AddOrEditCookieDialog.ui
+    uis/BrowserView.ui
+    uis/CookiesDialog.ui
+    uis/DomainSettingsDialog.ui
+    uis/SettingsGeneral.ui
+    uis/SettingsPrivacy.ui
 )
 
 # Link the following libraries.
 target_link_libraries(privacy-browser
-    KF5::ConfigWidgets
+    Qt5::Core
+    Qt5::Gui
+    Qt5::Sql
+    Qt5::Widgets
+    Qt5::WebEngineCore
+    Qt5::WebEngineWidgets
     KF5::Completion
+    KF5::ConfigWidgets
     KF5::CoreAddons
     KF5::Crash
     KF5::DBusAddons
+    KF5::DocTools
     KF5::I18n
     KF5::XmlGui
-    Qt5::Widgets
-    Qt5::WebEngineWidgets
 )
 
+# Add the subdirectories.
+add_subdirectory(dialogs)
+add_subdirectory(filters)
+add_subdirectory(helpers)
+add_subdirectory(interceptors)
+add_subdirectory(structs)
+add_subdirectory(ui.rcs)
+add_subdirectory(views)
+add_subdirectory(windows)
+
 # Install Privacy Browser using the default KDE arguments.
 install(TARGETS privacy-browser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
 
@@ -65,8 +80,5 @@ install(PROGRAMS com.stoutner.privacybrowser.desktop DESTINATION ${KDE_INSTALL_A
 # Install Privacy Browser's metadata file.
 install(FILES com.stoutner.privacybrowser.appdata.xml DESTINATION ${KDE_INSTALL_METAINFODIR})
 
-# Install Privacy Browser's RC (Runtime Configuration) file.
-install(FILES privacybrowserui.rc DESTINATION ${KDE_INSTALL_KXMLGUI5DIR}/privacybrowser)
-
 # Install Privacy Browser's icon.
 ecm_install_icons(ICONS icons/sc-apps-privacy-browser.svg DESTINATION ${KDE_INSTALL_ICONDIR})