Add an option to use a bottom app bar. https://redmine.stoutner.com/issues/749
[PrivacyCell.git] / app / build.gradle
index 5fb6c7ede92e97b99d8ff582ace6c32521f1e6c1..51116f0b02b221a8f0e912c659c05ddb56964f59 100644 (file)
@@ -29,8 +29,8 @@ android {
         applicationId "com.stoutner.privacycell"
         minSdk 30
         targetSdk 30
-        versionCode 1
-        versionName "1.0"
+        versionCode 2
+        versionName "1.1"
     }
 
     buildTypes {
@@ -45,21 +45,17 @@ android {
             proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 'proguard-rules.pro'
         }
     }
-
-    compileOptions {
-        sourceCompatibility JavaVersion.VERSION_1_8
-        targetCompatibility JavaVersion.VERSION_1_8
-    }
-
-    kotlinOptions {
-        jvmTarget = '1.8'
-    }
 }
 
 dependencies {
     // Include the following AndroidX libraries.
-    implementation 'androidx.core:core-ktx:1.6.0'
     implementation 'androidx.appcompat:appcompat:1.3.1'
+    implementation 'androidx.core:core-ktx:1.6.0'
+    implementation 'androidx.preference:preference-ktx:1.1.1'
+    implementation 'androidx.webkit:webkit:1.4.0'
+
+    // Include the Kotlin standard libraries.  This should be the same version number listed in project build.gradle.
+    implementation 'org.jetbrains.kotlin:kotlin-stdlib-jdk8:1.5.30'
 
     // Include the Google material library.
     implementation 'com.google.android.material:material:1.4.0'