]> gitweb.stoutner.com Git - PrivacyBrowserPC.git/blobdiff - src/CMakeLists.txt
Add a man file.
[PrivacyBrowserPC.git] / src / CMakeLists.txt
index 2d1340b2fa06eac0509103d111fc3b8d9489c8b1..c4459c36044d6744c1582be20be4e1c99130f9a0 100644 (file)
 # along with Privacy Browser PC.  If not, see <http://www.gnu.org/licenses/>.
 
 # Create the executable and add the resources.
-add_executable(privacy-browser resources.qrc)
+add_executable(privacybrowser resources.qrc)
 
 # List the sources to include in the executable.
-target_sources(privacy-browser PRIVATE
+target_sources(privacybrowser PRIVATE
     main.cpp
 )
 
 # Add the Qt logging category.  This will create the `debug.h` header file.
-ecm_qt_declare_logging_category(privacy-browser
+ecm_qt_declare_logging_category(privacybrowser
     HEADER debug.h
     IDENTIFIER PRIVACYBROWSER
     CATEGORY_NAME "privacybrowser"
 )
 
 # Include the KConfig controller file.
-kconfig_add_kcfg_files(privacy-browser settings/Settings.kcfgc)
+kconfig_add_kcfg_files(privacybrowser settings/Settings.kcfgc)
 
 # Use KDE Frameworks to handle internationalization of the following UI files.
-ki18n_wrap_ui(privacy-browser
+ki18n_wrap_ui(privacybrowser
     uis/AddOrEditCookieDialog.ui
     uis/AddTabWidget.ui
     uis/CookiesDialog.ui
@@ -48,7 +48,7 @@ ki18n_wrap_ui(privacy-browser
 )
 
 # Link the following libraries.
-target_link_libraries(privacy-browser
+target_link_libraries(privacybrowser
     Qt5::Core
     Qt5::Gui
     Qt5::Sql
@@ -80,7 +80,7 @@ add_subdirectory(widgets)
 add_subdirectory(windows)
 
 # Install Privacy Browser using the default KDE arguments.
-install(TARGETS privacy-browser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
+install(TARGETS privacybrowser ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
 
 # Install Privacy Browser according to the instructions in the desktop file, specifying the permissions.
 install(PROGRAMS com.stoutner.privacybrowser.desktop DESTINATION ${KDE_INSTALL_APPDIR} PERMISSIONS OWNER_READ OWNER_WRITE GROUP_READ WORLD_READ)
@@ -92,4 +92,4 @@ install(FILES com.stoutner.privacybrowser.appdata.xml DESTINATION ${KDE_INSTALL_
 install(FILES privacybrowser.notifyrc DESTINATION ${KDE_INSTALL_KNOTIFYRCDIR})
 
 # Install Privacy Browser's icon.
-ecm_install_icons(ICONS icons/sc-apps-privacy-browser.svg DESTINATION ${KDE_INSTALL_ICONDIR})
+ecm_install_icons(ICONS icons/sc-apps-privacybrowser.svg DESTINATION ${KDE_INSTALL_ICONDIR})